Cannot complete the install because one or more required items could not be found. Software being installed: Subversion Revision Graph 1.0.9

Cannot complete the install because one or more required items could not be found.
Software being installed: Subversion Revision Graph 1.0.9 (org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.9)
Missing requirement: Subversion Revision Graph 1.0.9 (org.tigris.subversion.subclipse.graph.feature.feature.group 1.0.9) requires ‘org.eclipse.draw2d 3.2.0′ but it could not be found

If you happen to get this error while installing the Subclipse plugin on Aptana Studio 3, it means you need to install the Graphical Editing Framework Draw2d first, which is not included in the current Aptana Studio 3 package.

Draw2d is part of GEF, which you can get from http://download.eclipse.org/tools/gef/updates-pre-3_8/releases/. Draw2d is the first package when you expand the GEF from the menu. No need to install the other items unless you know that you need them for something else.

2 thoughts on “Cannot complete the install because one or more required items could not be found. Software being installed: Subversion Revision Graph 1.0.9

  1. Cannot complete the install because one or more required items could not be found.
    Software being installed: Google App Engine Java SDK 1.6.0 1.6.0.v201111171704r35 (com.google.appengine.eclipse.sdkbundle.e35.feature.feature.group 1.6.0.v201111171704r35)
    Missing requirement: Google App Engine Plugin 2.4.2.relr35v201110112027 (com.google.appengine.eclipse.core 2.4.2.relr35v201110112027) requires ‘bundle org.eclipse.wst.xml.core 0.0.0′ but it could not be found
    Cannot satisfy dependency:
    From: Google App Engine SDK 1.6.0.v201111171704r35 (com.google.appengine.eclipse.sdkbundle 1.6.0.v201111171704r35)
    To: bundle com.google.appengine.eclipse.core 0.0.0
    Cannot satisfy dependency:
    From: Google App Engine Java SDK 1.6.0 1.6.0.v201111171704r35 (com.google.appengine.eclipse.sdkbundle.e35.feature.feature.group 1.6.0.v201111171704r35)
    To: com.google.appengine.eclipse.sdkbundle [1.6.0.v201111171704r35]

  2. there is not nightmare greater than developing an plugin to Eclipse! most of times its impossible to resolve so many dependencies and deal with conflicts.
    sometimes its really ridiculous.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>